当前栏目>>广元气象>>气象科普>>科普文摘
 

易语言中使用surfer控件绘制自动站雨量等值线程序

发布时间:2012/7/30 13:40:51

信息来源:广元市气象局  


.子程序 _雨量等值线_被选择
.局部变量 SurferApp, 对象
.局部变量 PicName, 文本型
.局部变量 Documents, 对象
.局部变量 contourmap, 对象
.局部变量 PostMap, 对象
.局部变量 PostMapFrame, 对象
.局部变量 BaseMap, 对象
.局部变量 BaseMap1, 对象
.局部变量 ContourmapFrame, 对象
.局部变量 FontLabel, 字体
.局部变量 AddText, 对象

.如果 (SurferApp.创建 (“Surfer.Application”, ) = 真 且 统计文本1.选中 = 真 且 雨量文件列表.被选择文件 ≠ “”)
    SurferApp.逻辑方法 (“GridData”, 雨量文件列表.目录 + “\” + 雨量文件列表.被选择文件, 1, 2, 3, , , , , , , 104.5, 106.8, 31.5, 33, , 假, , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , 取运行目录 () + “\drawcontour.grd”, 2, , , , , , , )
    SurferApp.逻辑方法 (“GridBlank”, 取运行目录 () + “\drawcontour.grd”, 取运行目录 () + “\map\gymap.bln”, 取运行目录 () + “\Out.grd”, 2)
    PicName = 取运行目录 () + “\pic\” + 取文本中间 (雨量文件列表.被选择文件, 1, 21) + “.jpg”
    Documents = SurferApp.读对象型属性 (“Documents”, ).对象型方法 (“add”, 1)
    ContourmapFrame = Documents.读对象型属性 (“shapes”, ).对象型方法 (“AddContourMap”, 取运行目录 () + “\Out.grd”)
    contourmap = ContourmapFrame.读对象型属性 (“Overlays”, ).对象型方法 (“Item”, 1)
    contourmap.读对象型属性 (“Levels”, ).对象型方法 (“LoadFile”, 取运行目录 () + “\color1.lvl”)
    contourmap.写属性 (“SmoothContour”, 4)
    contourmap.写属性 (“ShowColorScale”, 真)
    contourmap.写属性 (“FillContours”, 真)
    BaseMap = Documents.读对象型属性 (“shapes”, ).对象型方法 (“AddBaseMap”, 取运行目录 () + “\map\gymap.bln”)
    BaseMap1 = Documents.读对象型属性 (“shapes”, ).对象型方法 (“AddBaseMap”, 取运行目录 () + “\map\gyxian.bln”)
    PostMapFrame = Documents.读对象型属性 (“shapes”, ).对象型方法 (“AddPostMap”, 取运行目录 () + “\station.txt”, 1, 2, 3, 0, 0)
    PostMap = PostMapFrame.读对象型属性 (“Overlays”, ).对象型方法 (“Item”, 1)
    PostMap.写属性 (“LabelPos”, 5)
    PostMap.读对象型属性 (“Symbol”, ).写属性 (“Size”, 0.02)
    PostMap.读对象型属性 (“Symbol”, ).写属性 (“Index”, 45)
    PostMap.读对象型属性 (“LabelFont”, ).写属性 (“Face”, “宋体”)
    PostMap.读对象型属性 (“LabelFont”, ).写属性 (“Size”, 6)
    AddText = Documents.读对象型属性 (“shapes”, ).对象型方法 (“AddText”, 3, 3, “广元市” + 取文本中间 (雨量文件列表.被选择文件, 1, 21) + “自动站雨量等值线”)
    AddText.读对象型属性 (“Font”, ).写属性 (“Face”, “宋体”)
    AddText.读对象型属性 (“Font”, ).写属性 (“Size”, “12”)
    Documents.读对象型属性 (“shapes”, ).对象型方法 (“SelectAll”, )
    Documents.读对象型属性 (“Selection”, ).对象型方法 (“OverlayMaps”, )
    Documents.逻辑方法 (“Export”, PicName, 真, “Width=” + 到文本 (图片框1.宽度) + “,height=” + 到文本 (图片框1.高度))
    SurferApp.方法 (“Quit”, )
    图片框1.图片 = 读入文件 (PicName)
.否则

责任编辑:李志华

本信息已经被9755人浏览

 
 

关闭窗口

 

© 2009 版权所有 广元市气象局 广元市气象学会 站长信箱:tysword@163.com
地址:四川省广元市利州东路800号   邮编:628017